Movable Type 5.2.2

Позавчера выпустили новую версию Movable Type 5.2.2. Одновременно с этим начался этап в нумеровании и выпуске новых версий.

Теперь, как и прежде, мажорные версии (4.x, 5.x) будут выходить с периодичностью в 2-3 года, промежуточные версии (5.2, 5.3, 5.4) — раз в полгода-год, а версии с незначительными изменениями (5.2.2, 5.2.3, 5.2.4) — раз в месяц-два. Как заверяют разработчики, такой подход позволит более оперативно устранять ошибки и вводить новый функции.

Но релиз 5.2.2 сложно назвать незначительным: устранено 76 ошибок, по умолчанию стала новая тема «Rainier», а также появилась возможность создавать текстовые шаблоны (Boilerplate Text), которые затем можно вставлять в записи блога.

Скачать новые версии:

Комментариев: 20

Удивительная история!
Установил 5.2.2, и у меня на всех четырех браузерах не отображается поле для редактора (при создании новой записи), просто пустое пространство между вкладками "Текст", "Продолжение" и полем "Теги", а на другом сайте, где версия еще 5.2, все в порядке!
Отчего это может быть?

Возможно, неправильно загрузились статичные файлы, вы как загружали дистрибутив?

Загрузил архив по ftp, на сервере распаковал. Хостинг Ру центр.

Тогда эта проблема исключается.

Я устанавливал 5.2.2 несколько раз для различных тестов, также этот сайт работает на этой версии. Во всех случаях подобной проблемы не было.

Можно попробовать посмотреть логи ошибок сервера, может быть там будет информация, какие-нибудь отсутствующие файлы или доступ к чему-нибудь закрыт.

Также можно в браузере открыть «инструменты для разработчиков» (в каждом браузере по-разному называется), после открытия обновить страницу и посмотреть, есть ли какие-нибудь ошибки.

Вот такая вот запись в "Console" (Гугл хром):
GET http://gazeta-nk.ru/mt-static//plugins/TinyMCE/tiny_mce/langs/ru.js 404 (Not Found) tiny_mce.js:1
Failed to load: http://gazeta-nk.ru/mt-static//plugins/TinyMCE/tiny_mce/langs/ru.js tiny_mce.js:1
GET http://gazeta-nk.ru/mt-static//plugins/TinyMCE/tiny_mce/themes/advanced/langs/ru.js 404 (Not Found) tiny_mce.js:1
Failed to load: http://gazeta-nk.ru/mt-static//plugins/TinyMCE/tiny_mce/themes/advanced/langs/ru.js

В этом может быть дело?

Да, скорее всего, именно в этом. Сейчас смотрю, почему так получилось, а также обновляю дистрибутив.

Тогда понятно. А когда можно будет дополненный дистрибутив скачать? И можно ли проверить, не упустились ли еще какие-нибудь файлы?

Ссылка на недостающие файлы ниже. А сами дистрибутивы уже обновлены.

Перед выкладыванием новой версии я сравниваю при помощи команды diff 2 версии: оригинальную и русскую. Можно самостоятельно проверить, команда такая:

diff -i -E -b -w -B -u MT-ORIGIN MT-RU > history.diff

Где «MT-ORIGIN» — это директория с оригинальным дистрибутивом, а «MT-RU» — с русским.
В итоге будет создан файл history.diff со списком изменений относительно оригинальной версии.

Все понятно, спасибо! Файлики залил, заработало.

Но вы же проверили уже, больше же не было недостающих файлов?

Да, всё в порядке, только что проверил ещё раз.

/plugins/TinyMCE/tiny_mce/themes/advanced/langs/ru.js Так этого файла и в дистрибутиве нет, только что проверил

а в 5.2 есть о_0

Сравнил настройки хостинга для работающего сайта и этого второго. Вроде бы все выставлено одинаково

Итак, недостающие файлы: http://movable-type.ru/downloads/other/mt-static-TinyMCE-fix.zip
(Структура папок сохранена.)
Спасибо, что обратили на этой внимание, так бы непонятно когда это всплыло :)

Скажите, пожалуйста, в русской 5.2.2 есть проблема с max_user_connections при установке?

Это не от версии зависит, а от хостера, который ограничил количество одновременных соединений к серверу MySQL.

Это зависит от э... станностей, появившихся в этой версии :) Глубоко не копал, но вот: http://klopp.dreamwidth.org/39005.html?thread=15965#cmt15965

Новая проблема: не объединяются одинаковые теги. То есть при создании, например, двух записей, к каждой добавляется один и тот же тег (на русском языке). Затем и в облаке тегов и в "Управлении тегами" в админке, они показываются отдельно, как разные, хотя являются абсолютно идентичными

Это может быть из-за кодировки базы данных. Такой ошибки не возникает, когда кодировка utf8_general_ci.

Понял, разобрался. Спасибо!

Комментировать

Статистика

Яндекс.Метрика

Последние записи

  • Обновился сайт с плагинами

    Сайт plugins.movabletype.org, долгое время находившийся в полурабочем состоянии, вновь стал рабочим. У каждого плагина появились обнозначения о совместимости со старыми и новыми версиями. Также многие...

  • Где искать плагины для Movable Type

    Давным давно разработчики Movable Type перенесли совместную работу с кодом на Гитхаб. Благодаря этому, а также стандарту именования плагинов, поиск на Гитхабе находит уже 701...

  • Movable Type 5.2.10

    Изменения в новой версии незначительны, только исправления небольшой угрозы безопасности. Скачать новую версию: 5.2.10 в zip-архиве 5.2.10 в tar.gz-архиве Только изменённые файлы (в сравнении с...

  • Основные нововведения в Movable Type 6

    В шестой версии появилось несколько новшеств, которых нет ни в одной другой системе управления контентом, и благодаря которым Movable Type стал ещё лучше. Data API...

  • Movable Type 5.2.9

    В новой версии нет значительных изменения, обновление касается только безопасности системы — была устранена ошибка, благодаря которой была возможна XSS-атака через визуальный редактор. Скачать новую...

Закрыть