Movable Type 4.35 и 5.04

Сегодня вышли обновления для обеих веток Movable Type, затрагивающие безопасность системы. Рекомендуется обновиться до этих версий.

Скачать Movable Type 4.35:

Скачать Movable Type 5.04:

Обновление от 10 декабря (для версии 5.04): если у вас возникала ошибка «failed loading package MT::Template::Tags::Comment for routine MT::Template::Tags::Comment::_hdlr_if_comments_active: Global symbol "$label" requires explicit package name», смотрите эту тему форума.

Комментариев: 11

Спасибо за релиз, придётся обновляться не откладывая в долгий ящик

Ну да, с такими обновлениями тянуть не стоит :)

Здравствуйте. Новая версия это просто прекрасно, но вот сколько я пытаюсь найти, а внятного мануала по настройки и началу работы найти на ресурсах русской поддержки MT найти не могу. Может смотрю не туда? Спасибо за ответ.

Вообще, основные статьи есть здесь: http://movable-type.ru/wiki/

если цель - создать обычный блог - то видимо лучше использовать 4 версию ?

а то в 5 версии - я понимаю так, что обязательное условие сначала создать сайт, потом в нем сделать блог, который может быть только в поддиректории этого сайта

Да, в 5-й версии без сайта блог не создать. 4-я именно для блога лучше подходит. Здесь, например, используется именно 4-я версия. Большинство плагинов также совместимы с этой версией. Но кому-то больше нравится интерфейс 5-й версии.

в 5 версии почему то при создании нового сайта в другом домене - он публикуется, но без классического дизайна.

странно как то, 2 раза пробовал на 2-х разных доменах в пределах одного хостинга.

нашел в чем дело - в стилях styles.css неправильно прописывается импорт урл главного сайта, где установлен MV

это ошибка в скрипте ? или где то есть настройки какие то для мультидоменности ?

Здесь может быть проблема в том, что в конфиге указан относительный URL, а не абсолютный. Например, /mt-static/, вместо http://example.com/mt-static/.

или нужно каждый раз копировать по фтп папку MT static вручную по фтп при создании на другом домене

P.S. "запомнить меня" в форме комментирования не работает

Попытался поставить на локальном (winXP SP3, денвер) версию 4.35. После
"Проверка необходимых компонентов
Все обязательные модули Perl найдены. Вы можете приступить к установке Movable Type." нажал "Продолжить" и получил:
"Movable Type
Произошла ошибка
close Недопустимый запрос: неверный символ для кодировки UTF-8"

Посмотрите в форуме, там подобные вопросы обсуждались. А так же в Wiki: http://movable-type.ru/wiki/Установка_и_настройка_Denwer

Статистика

Яндекс.Метрика

Последние записи

  • Обновился сайт с плагинами

    Сайт plugins.movabletype.org, долгое время находившийся в полурабочем состоянии, вновь стал рабочим. У каждого плагина появились обнозначения о совместимости со старыми и новыми версиями. Также многие...

  • Где искать плагины для Movable Type

    Давным давно разработчики Movable Type перенесли совместную работу с кодом на Гитхаб. Благодаря этому, а также стандарту именования плагинов, поиск на Гитхабе находит уже 701...

  • Movable Type 5.2.10

    Изменения в новой версии незначительны, только исправления небольшой угрозы безопасности. Скачать новую версию: 5.2.10 в zip-архиве 5.2.10 в tar.gz-архиве Только изменённые файлы (в сравнении с...

  • Основные нововведения в Movable Type 6

    В шестой версии появилось несколько новшеств, которых нет ни в одной другой системе управления контентом, и благодаря которым Movable Type стал ещё лучше. Data API...

  • Movable Type 5.2.9

    В новой версии нет значительных изменения, обновление касается только безопасности системы — была устранена ошибка, благодаря которой была возможна XSS-атака через визуальный редактор. Скачать новую...

Закрыть