Интегрированная подержка FastCGI

8 января Six Apart анонсировала новую версию Movable Type 3.34 (пока только бета). Основные изменения устраняют проблемы безопасности и найденные ошибки. Полноценная версия должна появиться после 15 числа.

А вчера было анонсировано, что в версии 3.34 будет интегрированная поддержка FastCGI. Пользователям, установившим новую версию, не нужно будет устанавливать каких-то специальных плагинов или изменять файлы для запуска Movable Type из под FastCGI.

1 трекбэк

Movable Type 3.34 от «Movable Type» — 18.01.2007 09:05

Несколько часов назад SixApart анонсировала новую версию Movable Type 3.34. Как и сообщалось ранее , в новой версии появилась интегрированная поддержка FastCGI, а также были устранены потенциальные уя... Читать дальше

Комментариев: 5


На мой вкус, поддержка FastCGI нужна для динамической публикации. А интерфейс и так вполне работает.

А из анонса создается впечатление, что это вместо mod_perl-а. А зачем ?

Да, админка и так прекрасно работает. Но вот спамеры могут конкретно достать, отправляя одновременно десятки (сотни) запросов на один скрипт.
Если будет интегрированная поддержка FastCGI, (т.е. не нужно будет менять никаких файлов, только изменить расширение двух скриптов - для комментариев и трекбэков), то это может здорово помочь. Особенно порадует, если сделают без необходимости указывать в каком режиме работает MT - в обычном или FastCGI.

А зачем менять расширение ? И Apache и standalone FCGI вполне без этого позволяют.

А что касается спамеров, так надо сериализовать обращение к mt.cgi (хоть через mod_accel, хоть через что) и не будут мешать.

P.S. Попытался зайти через OpenID, меня обругало:

This blog requires email addresses from commenters, which are not available when signing in with OpenID. Please inform the owner of the blog that the "Require E-mail Address" option should be disabled to allow OpenID sign-ins.

OpenID поправил, там в настройках блога нужно нужно было снять галочку об обязательности e-mail.

А зачем менять расширение ? И Apache и standalone FCGI вполне без этого позволяют.
Вопрос: как? Я знаю, как можно с помощью .htaccess заставить Apache обрабатывать .cgi как fcgi.

Статистика

Яндекс.Метрика

Последние записи

  • Обновился сайт с плагинами

    Сайт plugins.movabletype.org, долгое время находившийся в полурабочем состоянии, вновь стал рабочим. У каждого плагина появились обнозначения о совместимости со старыми и новыми версиями. Также многие...

  • Где искать плагины для Movable Type

    Давным давно разработчики Movable Type перенесли совместную работу с кодом на Гитхаб. Благодаря этому, а также стандарту именования плагинов, поиск на Гитхабе находит уже 701...

  • Movable Type 5.2.10

    Изменения в новой версии незначительны, только исправления небольшой угрозы безопасности. Скачать новую версию: 5.2.10 в zip-архиве 5.2.10 в tar.gz-архиве Только изменённые файлы (в сравнении с...

  • Основные нововведения в Movable Type 6

    В шестой версии появилось несколько новшеств, которых нет ни в одной другой системе управления контентом, и благодаря которым Movable Type стал ещё лучше. Data API...

  • Movable Type 5.2.9

    В новой версии нет значительных изменения, обновление касается только безопасности системы — была устранена ошибка, благодаря которой была возможна XSS-атака через визуальный редактор. Скачать новую...

Закрыть